IVY DOM


 

人生就像一副复杂拼图
每个人总有属於自己的记忆碎片
优质美国空间-老薛主机|IVY DOM|Flowline|

联系我

RSS




十月 02, 2011

[源码]易语言海绵宝宝播放器

.版本 2
.支持库 internet
.支持库 iext
.支持库 HtmlView

.程序集 窗口程序集1
.程序集变量 项目数据, QQ项目数据
.程序集变量 QQ列表1, QQ列表模仿类
.程序集变量 地址尾, 文本型

.子程序 __启动窗口_创建完毕

寻找 ()

.子程序 播放
.参数 播放地址, 文本型
.局部变量 a, 整数型
.局部变量 b, 整数型
.局部变量 c, 文本型
.局部变量 d, 文本型

c = 到文本 (HTTP读文件 (播放地址))
a = 寻找文本 (c, “http://player.youku.com/”, , 假)
b = 寻找文本 (c, “swf”, a, 假)
d = 取文本中间 (c, a, b - a + 3)
‘ 写到文件 (读环境变量 (“TEMP”) + “movie.html”, 到字节集 (#数据头 + d + #地址尾 + #数据尾))
‘ 超文本浏览框1.地址 = 读环境变量 (“TEMP”) + “movie.html”

.子程序 插入
.局部变量 a, 文本型, , “0”
.局部变量 i5, 整数型
.局部变量 b, 文本型, , “0”
.局部变量 o, 整数型

‘ http://www.soku.com/search_video/q_
a = 分割文本 (编辑框1.内容, “|”, )
.计次循环首 (取数组成员数 (a), i5)
b = 分割文本 (a [i5], “|”, )
超级列表框1.插入表项 (i5 - 1, , , , , )
.计次循环首 (取数组成员数 (b), o)
超级列表框1.置标题 (i5 - 1, o - 1, b [o])
地址尾 = b [o]
.计次循环尾 ()
.计次循环尾 ()

.子程序 寻找
.局部变量 i, 整数型
.局部变量 i2, 整数型
.局部变量 分组句柄, 整数型
.局部变量 i3, 整数型
.局部变量 a, 文本型, , “0”
.局部变量 i5, 整数型
.局部变量 b, 文本型, , “0”
.局部变量 o, 整数型
.局部变量 i4, 整数型

‘ http://www.soku.com/search_video/q_
‘ http://tieba.baidu.com/%BA%A3%C3%E0%B1%A6%B1%A6/shipin/plays/%D1%EB%CA%D3%B0%E6%BA%A3%C3%E0%B1%A6%B1%A6120%BC%AF/#videoId=6cf55d2264873c2b125a9ac7
‘ http://tieba.baidu.com/%BA%A3%C3%E0%B1%A6%B1%A6/shipin/plays/%D1%EB%CA%D3%B0%E6%BA%A3%C3%E0%B1%A6%B1%A6120%BC%AF/#videoId=78b9d189678ad9b9ddb7c27d
‘ http://tieba.baidu.com/%BA%A3%C3%E0%B1%A6%B1%A6/shipin/plays/%D1%EB%CA%D3%B0%E6%BA%A3%C3%E0%B1%A6%B1%A6120%BC%AF/#videoId=
‘ http://www.soku.com/search_video/q_
‘ http://mv.baidu.com/export/flashplayer.swf?vid=
a = 分割文本 (编辑框1.内容, “|”, )
.计次循环首 (取数组成员数 (a), i5)
b = 分割文本 (a [i5], “|”, )
超级列表框1.插入表项 (i5 - 1, , , , , )
.计次循环首 (取数组成员数 (b), o)
超级列表框1.置标题 (i5 - 1, o - 1, b [o])
地址尾 = b [o]
‘ 编辑框3.内容 = 地址尾
.计次循环尾 ()
.计次循环尾 ()
i3 = 0
QQ列表1.创建 (图片框2.取窗口句柄 (), 0, 1, 假, )
QQ列表1.置分组颜色风格 (, , )
QQ列表1.设置事件 (, &QQ列表事件_项目双击)
分组句柄 = QQ列表1.添加分组 (“剧集列表”, 真, #红色)
.计次循环首 (121, i)
项目数据.分组句柄 = 分组句柄
项目数据.QQ名称 = “海绵宝宝第” + 到文本 (i - 1) + “集”
项目数据.头像图片数据 = #QQ
项目数据.个性签名 = “海绵宝宝 ” + “第” + 到文本 (i - 1) + “集”
项目数据.是否在线 = 真
项目数据.备注信息 = “http://mv.baidu.com/export/flashplayer.swf?vid=” + 超级列表框1.取标题 (i - 1, 0)
QQ列表1.添加项目 (项目数据, )
.计次循环首 (119, )
‘ i3 = i3 + 1
‘ 地址尾 = 超级列表框1.取标题 (i5 - 1, o - 1)
‘ 项目数据.备注信息 = “http://mv.baidu.com/export/flashplayer.swf?vid=” + 地址尾
.计次循环尾 ()
‘ 项目数据.备注信息 = “http://mv.baidu.com/export/flashplayer.swf?vid=” + 地址尾
.计次循环尾 ()
QQ列表1.置列表类型_无图标 ()

.子程序 QQ列表事件_项目双击
.参数 项目句柄, 整数型, , 当前事件项目的句柄
.参数 横向位置, 整数型, , 鼠标位置
.参数 纵向位置, 整数型, , 鼠标位置
.局部变量 表项, 整数型
.局部变量 呃, 文本型
.局部变量 啊, 文本型
.局部变量 基址, 文本型

呃 = “海绵宝宝第”
啊 = “集”
基址 = “http://mv.baidu.com/export/flashplayer.swf?vid=”
QQ列表1.取项目数据 (项目句柄, 项目数据)
.如果真 (寻找文本 (项目数据.备注信息, “http://”, , 真) ≠ -1)
‘ 如果真 (项目数据.QQ名称 = 呃 + “1” + 啊)
X.地址 = 项目数据.备注信息
返回 ()
.如果真结束

.子程序 文本是否存在, 逻辑型, 公开
.参数 要寻找的文本, 文本型
.参数 被寻找的文本, 文本型
.参数 区分大小写否, 逻辑型

.如果 (寻找文本 (要寻找的文本, 被寻找的文本, 1, 区分大小写否) = -1)
返回 (假)
.否则
返回 (真)
.如果结束
用到了仿QQ列表模块~

这个源码我以前在易语言官方论坛发过一次= =因为某个地方写错了 寻求帮助的= =

相关文章

返回
  1. It’s much eieasr to understand when you put it that way!

  1. 暂无 Trackback

You must be logged in to post a comment.