IVY DOM


 

人生就像一副复杂拼图
每个人总有属於自己的记忆碎片
优质美国空间-老薛主机|IVY DOM|Flowline|

联系我

RSS




四月 03, 2012

[开源]马勒戈壁语言易语言版全开源!!!

.版本 2

.程序集 程序集1
.程序集变量 返回, 文本型
.程序集变量 数组_返回, 文本型, , “0”
.程序集变量 gobi, 文本型
.程序集变量 存储_gobi, 文本型
.程序集变量 数组_gobi, 文本型, , “0”
.程序集变量 存储_fucku, 文本型
.程序集变量 fucku, 文本型
.程序集变量 pingurgobi, 文本型
.程序集变量 存储_pingurgobi, 文本型
.程序集变量 gobih, 文本型
.程序集变量 存储_gobih, 文本型
.程序集变量 gobiw, 文本型
.程序集变量 存储_gobiw, 文本型
.程序集变量 gobiv, 文本型
.程序集变量 gobico, 文本型
.程序集变量 存储_gobico, 文本型
.程序集变量 delgobireg, 文本型
.程序集变量 存储_delgobireg, 文本型
.程序集变量 集合, 文本型
.程序集变量 存储_文件名, 文本型
.程序集变量 时间前, 整数型
.程序集变量 时间戳, 整数型
.程序集变量 addgobireg, 文本型
.程序集变量 存储_addgobireg, 文本型
.程序集变量 gobintr, 文本型
.程序集变量 ctopy, 文本型
.程序集变量 ctoasc, 文本型
.程序集变量 加法, 文本型
.程序集变量 减法, 文本型
.程序集变量 乘法, 文本型
.程序集变量 除法, 文本型
.程序集变量 乘方, 文本型
.程序集变量 gobitime, 文本型
.程序集变量 ftaskkill, 文本型

.子程序 _启动子程序, 整数型, , 本子程序在程序启动后最先执行

.如果 (文件是否存在 (取运行目录 () + “idost.exe”) = 真 且 文件是否存在 (取运行目录 () + “idostocompile.exe”) = 真 且 文件是否存在 (取运行目录 () + “com.exe”) = 真 且 文件是否存在 (取运行目录 () + “exe.exe”) = 真)
标准输出 (, “欢迎使用马勒戈壁语言,系统将带您到一个神圣的地带” + 字符 (10) + 字符 (13) + “输入命令行 /? 可以查看用法(?为英文状态下字符)” + 字符 (10) + 字符 (13) + “输入[debug 1]进行模拟测试,输入[help 1]查看语法大全,输入[help 2]查看帮助!” + 字符 (10) + 字符 (13) + “输入[cm 1]进行编译!” + 字符 (10) + 字符 (13))
时间前 = 取启动时间 ()
检查命令行语法 ()
标准输入 ()
.否则
信息框 (“调试/编译所需文件丢失!请从新下载!”, 0, “iGobiDOS”)
.如果结束

返回 (0)  ‘ 可以根据您的需要返回任意数值

.子程序 检查命令行语法

‘ 数组_返回[1]为整段命令行前半部分的关键TOKEN,数组_返回[2]为返回来的文本,为用户自定义输入的内容
返回 = 标准输入 ()  ‘ 获得用户输入的内容
数组_返回 = 分割文本 (返回, “ ”, )
.如果 (取数组成员数 (数组_返回) = 1)  ‘ 数组成员数量=1时表示只有前半部分的TOKEN,无后半部分
标准输出 (, “请输入命令行或命令行后缀文本!输入[end 1]再按回车退出程序!” + 字符 (10) + 字符 (13))
检查命令行语法 ()  ‘ 防止系统关闭
.否则
输出调试文本 (“命令行:” + 数组_返回 [1], “返回:” + 数组_返回 [2])
.如果真 (数组_返回 [1] = “cm”)
独立编译 ()
.如果真结束
.如果真 (数组_返回 [1] = “help”)
系统帮助_查看语法 ()
.如果真结束
.如果真 (数组_返回 [1] = “debug”)
模拟debug ()
.如果真结束
.如果真 (数组_返回 [1] = “end”)
结束 ()
.如果真结束
.如果真 (数组_返回 [1] = “文件名”)
命令行_文件名 ()
.如果真结束
.如果真 (数组_返回 [1] = “马勒戈壁”)
命令行_马勒戈壁 ()
gobi = 数组_返回 [2]
.如果真结束
.如果真 (数组_返回 [1] = “gobi”)
命令行_马勒戈壁 ()
gobi = 数组_返回 [2]
.如果真结束
.如果真 (数组_返回 [1] = “草泥马”)
命令行_草泥马 ()
fucku = “ ” + 删首尾空 (fucku) + “ ” + 数组_返回 [2] + “ ”
.如果真结束
.如果真 (数组_返回 [1] = “fucku”)
命令行_草泥马 ()
fucku = “ ” + 删首尾空 (fucku) + “ ” + 数组_返回 [2] + “ ”
.如果真结束
.如果真 (数组_返回 [1] = “与马勒戈壁通信”)
命令行_与马勒戈壁通信 ()
pingurgobi = 数组_返回 [2]
.如果真结束
.如果真 (数组_返回 [1] = “pingurgobi”)
命令行_与马勒戈壁通信 ()
pingurgobi = 数组_返回 [2]
.如果真结束
.如果真 (数组_返回 [1] = “马勒戈壁高”)
命令行_马勒戈壁高 ()
gobih = 数组_返回 [2]
.如果真结束
.如果真 (数组_返回 [1] = “gobih”)
命令行_马勒戈壁高 ()
gobih = 数组_返回 [2]
.如果真结束
.如果真 (数组_返回 [1] = “马勒戈壁宽”)
命令行_马勒戈壁宽 ()
gobiw = 数组_返回 [2]
.如果真结束
.如果真 (数组_返回 [1] = “gobiw”)
命令行_马勒戈壁宽 ()
gobiw = 数组_返回 [2]
.如果真结束
.如果真 (数组_返回 [1] = “马勒戈壁可视”)
命令行_马勒戈壁可视 ()
gobiv = 数组_返回 [2]
.如果真结束
.如果真 (数组_返回 [1] = “gobiv”)
命令行_马勒戈壁可视 ()
gobiv = 数组_返回 [2]
.如果真结束
.如果真 (数组_返回 [1] = “召唤草泥马”)
命令行_召唤草泥马 ()
.如果真结束
.如果真 (数组_返回 [1] = “@fucku”)
命令行_召唤草泥马 ()
.如果真结束
.如果真 (数组_返回 [1] = “马勒戈壁天色”)
命令行_马勒戈壁天色 ()
gobico = 数组_返回 [2]
.如果真结束
.如果真 (数组_返回 [1] = “gobico”)
命令行_马勒戈壁天色 ()
gobico = 数组_返回 [2]
.如果真结束
.如果真 (数组_返回 [1] = “删除马勒戈壁注册表”)
命令行_删除马勒戈壁注册表 ()
delgobireg = 数组_返回 [2]
.如果真结束
.如果真 (数组_返回 [1] = “delgobireg”)
命令行_删除马勒戈壁注册表 ()
delgobireg = 数组_返回 [2]
.如果真结束
.如果真 (数组_返回 [1] = “增加马勒戈壁注册表”)
命令行_增加马勒戈壁注册表 ()
addgobireg = 数组_返回 [2]
.如果真结束
.如果真 (数组_返回 [1] = “addgobireg”)
命令行_增加马勒戈壁注册表 ()
addgobireg = 数组_返回 [2]
.如果真结束
.如果真 (数组_返回 [1] = “马勒戈壁取指定内容”)
命令行_马勒戈壁取指定内容 ()
gobintr = 数组_返回 [2]
.如果真结束
.如果真 (数组_返回 [1] = “gobintr”)
命令行_马勒戈壁取指定内容 ()
gobintr = 数组_返回 [2]
.如果真结束
.如果真 (数组_返回 [1] = “汉字到拼音”)
命令行_汉字到拼音 ()
ctopy = 数组_返回 [2]
.如果真结束
.如果真 (数组_返回 [1] = “ctopy”)
命令行_汉字到拼音 ()
ctopy = 数组_返回 [2]
.如果真结束
.如果真 (数组_返回 [1] = “汉字到ASCII”)
命令行_汉字到ASCII ()
ctoasc = 数组_返回 [2]
.如果真结束
.如果真 (数组_返回 [1] = “ctoasc”)
命令行_汉字到ASCII ()
ctoasc = 数组_返回 [2]
.如果真结束
.如果真 (数组_返回 [1] = “+”)
命令行_加法运算 ()
加法 = 数组_返回 [2]
.如果真结束
.如果真 (数组_返回 [1] = “-”)
命令行_减法运算 ()
减法 = 数组_返回 [2]
.如果真结束
.如果真 (数组_返回 [1] = “*”)
命令行_乘法运算 ()
乘法 = 数组_返回 [2]
.如果真结束
.如果真 (数组_返回 [1] = “/”)
命令行_除法运算 ()
除法 = 数组_返回 [2]
.如果真结束
.如果真 (数组_返回 [1] = “^”)
命令行_乘方运算 ()
乘方 = 数组_返回 [2]
.如果真结束
.如果真 (数组_返回 [1] = “马勒戈壁时间”)
命令行_马勒戈壁时间 ()
gobitime = 数组_返回 [2]
.如果真结束
.如果真 (数组_返回 [1] = “gobitime”)
命令行_马勒戈壁时间 ()
gobitime = 数组_返回 [2]
.如果真结束
.如果真 (数组_返回 [1] = “强制结束进程”)
命令行_强制结束进程 ()
ftaskkill = 数组_返回 [2]
.如果真结束
.如果真 (数组_返回 [1] = “ftaskkill”)
命令行_强制结束进程 ()
ftaskkill = 数组_返回 [2]
.如果真结束

‘ 集合 = gobi + #换行符 + fucku + #换行符 + pingurgobi + #换行符 + gobih + #换行符 + gobiw + #换行符 + gobiv + #换行符 + gobico
‘ 输出调试文本 (集合)
‘ 写到文件 (“F:UsersxieyangDesktop” + “gobilan.bat”, )
检查命令行语法 ()
.如果结束

.子程序 命令行_马勒戈壁

.如果 (数组_返回 [2] = “/?”)
标准输出 (, “    马勒戈壁 用法” + 字符 (10) + 字符 (13) + “    后接您想输出的控制台标题,英文名为gobi(必须为小写字母)” + 字符 (10) + 字符 (13) + “    例如:马勒戈壁 跨时代!” + 字符 (10) + 字符 (13))
.否则
标准输出 (, “马勒戈壁の副标题=” + 数组_返回 [2] + 字符 (10) + 字符 (13))
存储_gobi = “title ” + 数组_返回 [2]
输出调试文本 (存储_gobi)
.如果结束

.子程序 命令行_草泥马
.局部变量 i, 整数型

.如果 (数组_返回 [2] = “/?”)
标准输出 (, “    草泥马 用法” + 字符 (10) + 字符 (13) + “    后接您想输出的内容,可以为任意数据类型,英文名为fucku(必须为小写字母)” + 字符 (10) + 字符 (13) + “    例如:草泥马 跨时代!” + 字符 (10) + 字符 (13))
.否则
标准输出 (, “马勒戈壁の输出内容=” + 数组_返回 [2] + 字符 (10) + 字符 (13))
加入成员 (数组_gobi, 数组_返回 [2])
.’ 计次循环首 (取数组成员数 (数组_gobi), i)
‘ ‘ 存储_gobi = “echo ” + 数组_gobi [i]
.’ 计次循环尾 ()
存储_fucku = 存储_fucku + #换行符 + “echo ” + 数组_返回 [2]
输出调试文本 (存储_fucku)
.如果结束

.子程序 命令行_与马勒戈壁通信

.如果 (数组_返回 [2] = “/?”)
标准输出 (, “    与马勒戈壁通信 用法” + 字符 (10) + 字符 (13) + “    后接您想通信到的IP或域名,俗称ping,你懂的,英文名为pingurgobi(必须为小写字母)” + 字符 (10) + 字符 (13) + “    例如:与马勒戈壁通信 138.138.138.138” + 字符 (10) + 字符 (13))
.否则
标准输出 (, “欲与马勒戈壁通信のIP/域名=” + 数组_返回 [2] + 字符 (10) + 字符 (13))
存储_pingurgobi = “ping ” + 数组_返回 [2]
输出调试文本 (存储_pingurgobi)
.如果结束

.子程序 命令行_马勒戈壁高

.如果 (数组_返回 [2] = “/?”)
标准输出 (, “    马勒戈壁高 用法” + 字符 (10) + 字符 (13) + “    表示输出控制台的高度,英文名为gobih(必须为小写字母)” + 字符 (10) + 字符 (13) + “    例如:马勒戈壁高 64” + 字符 (10) + 字符 (13))
.否则
标准输出 (, “马勒戈壁の高=” + 数组_返回 [2] + 字符 (10) + 字符 (13))
存储_gobih = “mode con cols=” + 数组_返回 [2]
.如果结束

.子程序 命令行_马勒戈壁宽

.如果 (数组_返回 [2] = “/?”)
标准输出 (, “    马勒戈壁宽 用法” + 字符 (10) + 字符 (13) + “    表示输出控制台的宽度,英文名为gobiw(必须为小写字母)” + 字符 (10) + 字符 (13) + “    例如:马勒戈壁宽 89” + 字符 (10) + 字符 (13))
.否则
标准输出 (, “马勒戈壁の宽=” + 数组_返回 [2] + 字符 (10) + 字符 (13))
存储_gobiw = “ lines=” + 数组_返回 [2]
.如果结束

.子程序 命令行_马勒戈壁可视

.如果 (数组_返回 [2] = “/?”)
标准输出 (, “    马勒戈壁可视 用法” + 字符 (10) + 字符 (13) + “    表示输出控制台是否回显,后接真或假,真表示pause.若填写字母、数字或其他汉字系统将默认为假.英文名为gobiv(必须为小写字母)” + 字符 (10) + 字符 (13) + “    例如:马勒戈壁可视 真” + 字符 (10) + 字符 (13))
.否则
标准输出 (, “马勒戈壁の可视=” + 数组_返回 [2] + 字符 (10) + 字符 (13))
.如果结束

.子程序 命令行_召唤草泥马

.如果 (数组_返回 [2] = “/?”)
标准输出 (, “    召唤草泥马 用法” + 字符 (10) + 字符 (13) + “    打开某个网站.英文名为@fucku(必须为小写字母)” + 字符 (10) + 字符 (13) + “    例如:召唤草泥马 ivysoft.sinaapp.com” + 字符 (10) + 字符 (13))
.否则
标准输出 (, “召唤草泥马の网址=” + 数组_返回 [2] + 字符 (10) + 字符 (13))
运行 (“F:Program FilesInternet Exploreriexplore.exe ” + 数组_返回 [2], 假, )
.如果结束

.子程序 命令行_马勒戈壁天色

.如果 (数组_返回 [2] = “/?”)
标准输出 (, “    马勒戈壁天色 用法” + 字符 (10) + 字符 (13) + “    设置控制台背景色或前景,由十六进制指定,第一个位置的文本为背景,第二个为前景.英文名为gobico(必须为小写字母)” + 字符 (10) + 字符 (13) + “    例如:马勒戈壁天色 2F” + 字符 (10) + 字符 (13))
.否则
标准输出 (, “马勒戈壁の天色=” + 数组_返回 [2] + 字符 (10) + 字符 (13))
存储_gobico = “color ” + 数组_返回 [2]
.如果结束

.子程序 模拟debug

‘ 存储_gobi
.如果 (gobiv = “真”)
写到文件 (取运行目录 () + “” + 存储_文件名 + “.bat”, 到字节集 (“@echo off” + #换行符 + 存储_gobih + 存储_gobiw + #换行符 + 存储_gobico + #换行符 + 存储_gobi + #换行符 + 存储_fucku + #换行符 + 存储_delgobireg + #换行符 + 存储_addgobireg + #换行符 + “pause”))  ‘ 智能输入代码,准备工作
时间戳 = 取启动时间 () - 时间前
写配置项 (取运行目录 () + “config.ini”, “Debug”, “DebugTime”, 到文本 (时间戳))
运行 (取运行目录 () + “idost.exe”, 假, )  ‘ 运行独立调试器
.否则
写到文件 (取运行目录 () + “” + 存储_文件名 + “.bat”, 到字节集 (“@echo off” + #换行符 + 存储_gobih + 存储_gobiw + #换行符 + 存储_gobico + #换行符 + 存储_gobi + #换行符 + 存储_fucku + #换行符 + 存储_delgobireg + #换行符 + 存储_addgobireg))
运行 (取运行目录 () + “idost.exe”, 假, )
.如果结束

.子程序 系统帮助_查看语法

.如果真 (数组_返回 [2] = “1”)
标准输出 (, “    1.马勒戈壁 用法:” + 字符 (10) + 字符 (13) + “    后接您想输出的控制台标题,英文名为gobi(必须为小写字母)” + 字符 (10) + 字符 (13) + “    例如:马勒戈壁 跨时代!” + 字符 (10) + 字符 (13))
标准输出 (, “    2.草泥马 用法:” + 字符 (10) + 字符 (13) + “    后接您想输出的内容,可以为任意数据类型,英文名为fucku(必须为小写字母)” + 字符 (10) + 字符 (13) + “    例如:草泥马 跨时代!” + 字符 (10) + 字符 (13))
标准输出 (, “    3.与马勒戈壁通信 用:” + 字符 (10) + 字符 (13) + “    后接您想通信到的IP或域名,俗称ping,你懂的,英文名为pingurgobi(必须为小写字母)” + 字符 (10) + 字符 (13) + “    例如:与马勒戈壁通信 138.138.138.138” + 字符 (10) + 字符 (13))
标准输出 (, “    4.马勒戈壁高 用法:” + 字符 (10) + 字符 (13) + “    表示输出控制台的高度,英文名为gobih(必须为小写字母)” + 字符 (10) + 字符 (13) + “    例如:马勒戈壁高 64” + 字符 (10) + 字符 (13))
标准输出 (, “    5.马勒戈壁宽 用法:” + 字符 (10) + 字符 (13) + “    表示输出控制台的宽度,英文名为gobiw(必须为小写字母)” + 字符 (10) + 字符 (13) + “    例如:马勒戈壁宽 89” + 字符 (10) + 字符 (13))
标准输出 (, “    6.马勒戈壁可视 用法:” + 字符 (10) + 字符 (13) + “    表示输出控制台是否回显,后接真或假,真表示pause.若填写字母、数字或其他汉字系统将默认为假.英文名为gobiv(必须为小写字母)” + 字符 (10) + 字符 (13) + “    例如:马勒戈壁可视 真” + 字符 (10) + 字符 (13))
标准输出 (, “    7.马勒戈壁可视 用法:” + 字符 (10) + 字符 (13) + “    表示输出控制台是否回显,后接真或假,真表示pause.若填写字母、数字或其他汉字系统将默认为假.英文名为gobiv(必须为小写字母)” + 字符 (10) + 字符 (13) + “    例如:马勒戈壁可视 真” + 字符 (10) + 字符 (13))
标准输出 (, “    8.召唤草泥马 用法:” + 字符 (10) + 字符 (13) + “    打开某个网站.英文名为@fucku(必须为小写字母)” + 字符 (10) + 字符 (13) + “    例如:召唤草泥马 ivysoft.sinaapp.com” + 字符 (10) + 字符 (13))
标准输出 (, “    9.马勒戈壁天色 用法:” + 字符 (10) + 字符 (13) + “    设置控制台背景色或前景,由十六进制指定,第一个位置的文本为背景,第二个为前景.英文名为gobico(必须为小写字母)” + 字符 (10) + 字符 (13) + “    例如:马勒戈壁天色 2F” + 字符 (10) + 字符 (13))
标准输出 (, “    10.文件名 用法” + 字符 (10) + 字符 (13) + “    设置输出后的文件名,本命令行无英文” + 字符 (10) + 字符 (13) + “    例如:文件名 fuck” + 字符 (10) + 字符 (13))
标准输出 (, “    11.删除马勒戈壁注册表 用法” + 字符 (10) + 字符 (13) + “    删除注册表项及其所有子项和值(强行删除)” + 字符 (10) + 字符 (13) + “    例如:删除马勒戈壁注册表 HKEY_LOCAL_MACHINESOFTWAREFucking4” + 字符 (10) + 字符 (13))
标准输出 (, “    12.增加马勒戈壁注册表 用法” + 字符 (10) + 字符 (13) + “    增加一个注册表项(强行增加)” + 字符 (10) + 字符 (13) + “    例如:增加马勒戈壁注册表 HKEY_LOCAL_MACHINESOFTWAREFucking” + 字符 (10) + 字符 (13))
标准输出 (, “    13.马勒戈壁取指定内容 用法” + 字符 (10) + 字符 (13) + “    取得指定文本,英文字符为gobintr” + 字符 (10) + 字符 (13) + “    例如:马勒戈壁取指定内容 —-11111++++/—-/++++ 第一个/号前为全部文本,第二个/号前为左边文本,最后一个/号前为右边文本,返回的结果是11111” + 字符 (10) + 字符 (13))
标准输出 (, “    14.汉字到ASCII 用法” + 字符 (10) + 字符 (13) + “    将汉字转换为ASCII,智能转换,可同时转换多个字符,英文字符为ctoasc” + 字符 (10) + 字符 (13) + “    例如:汉字到ASCII 马勒戈壁上的草泥马,返回的结果是109 97 108 101 103 101 98 105 115 104 97 110 103 100 101 99 97 111 110 105 109 97” + 字符 (10) + 字符 (13))
标准输出 (, “    15.汉字到拼音 用法” + 字符 (10) + 字符 (13) + “    将汉字转换为拼音,智能转换,可同时转换多个字符,英文字符为ctopy” + 字符 (10) + 字符 (13) + “    例如:汉字到拼音 马勒戈壁上的草泥马,返回的结果ma le ge bi shang de cao ni ma” + 字符 (10) + 字符 (13))
标准输出 (, “    16.马勒戈壁时间 用法” + 字符 (10) + 字符 (13) + “    取时间,包括8个子集{现行,星期,季度,年份,日,小时,分钟,秒}英文符号为gobitime” + 字符 (10) + 字符 (13) + “    如果输入马勒戈壁时间 现行 则返回现在时间” + 字符 (10) + 字符 (13) + “    如果输入马勒戈壁时间 星期 则返回现在的星期” + 字符 (10) + 字符 (13) + “    如果输入马勒戈壁时间 季度 则返回现在的季度” + 字符 (10) + 字符 (13) + “    如果输入马勒戈壁时间 年份 则返回现在的年份” + 字符 (10) + 字符 (13) + “    如果输入马勒戈壁时间 日   则返回现在的日” + 字符 (10) + 字符 (13) + “    如果输入马勒戈壁时间 小时 则返回现在的小时” + 字符 (10) + 字符 (13) + “    如果输入马勒戈壁时间 秒   则返回现在的秒数” + 字符 (10) + 字符 (13))
标准输出 (, “    17.+ 用法” + 字符 (10) + 字符 (13) + “    使两个数字相加,格式为数值;数值” + 字符 (10) + 字符 (13) + “    例如:+ 1;1,返回的结果2” + 字符 (10) + 字符 (13))
标准输出 (, “    18./ 用法” + 字符 (10) + 字符 (13) + “    使两个数字相除,格式为除数;被除数” + 字符 (10) + 字符 (13) + “    例如:/ 4;2,返回的结果2” + 字符 (10) + 字符 (13))
标准输出 (, “    19.* 用法” + 字符 (10) + 字符 (13) + “    使两个数字相乘,格式为数值;数值” + 字符 (10) + 字符 (13) + “    例如:* 2;3,返回的结果6” + 字符 (10) + 字符 (13))
标准输出 (, “    20.+ 用法” + 字符 (10) + 字符 (13) + “    使两个数字相加,格式为数值;数值” + 字符 (10) + 字符 (13) + “    例如:- 2;1,返回的结果1” + 字符 (10) + 字符 (13))
标准输出 (, “    21.^ 用法” + 字符 (10) + 字符 (13) + “    求指定数值的指定次方,格式为欲求次方数值;次方数” + 字符 (10) + 字符 (13) + “    例如:^ 2;2,返回的结果4” + 字符 (10) + 字符 (13))
标准输出 (, “    22.强制结束进程 用法” + 字符 (10) + 字符 (13) + “    强力结束某进程,英文字符为ftaskkill” + 字符 (10) + 字符 (13) + “    例如:强制结束进程 FUCK.EXE” + 字符 (10) + 字符 (13))
.如果真结束
.如果真 (数组_返回 [2] = “2”)
标准输出 (, “    系统帮助:” + 字符 (10) + 字符 (13) + “    如果你想运行或编译为exe请务必写上[文件名 XXXX]!因为编译器、调试器与主程序相对独立,所以如果你没输入文件名将无法运行/调试!” + 字符 (10) + 字符 (13) + “    例如:文件名 跨时代” + 字符 (10) + 字符 (13))
.如果真结束

.子程序 命令行_文件名

.如果 (数组_返回 [2] = “/?”)
标准输出 (, “    文件名 用法” + 字符 (10) + 字符 (13) + “    设置输出后的文件名,本命令行无英文” + 字符 (10) + 字符 (13) + “    例如:文件名 fuck” + 字符 (10) + 字符 (13))
.否则
标准输出 (, “马勒戈壁の文件名=” + 数组_返回 [2] + 字符 (10) + 字符 (13))
存储_文件名 = 数组_返回 [2]
写配置项 (取运行目录 () + “config.ini”, “Debug”, “ToompileFileName”, 存储_文件名)
写配置项 (取运行目录 () + “config.ini”, “Debug”, “FileName”, 取运行目录 () + “” + 存储_文件名 + “.bat”)
.如果结束

.子程序 独立编译

运行 (取运行目录 () + “idostocompile.exe”, 假, )  ‘ 运行独立编译器

.子程序 命令行_删除马勒戈壁注册表

.如果 (数组_返回 [2] = “/?”)
标准输出 (, “    删除马勒戈壁注册表 用法” + 字符 (10) + 字符 (13) + “    删除注册表项及其所有子项和值(强行删除)” + 字符 (10) + 字符 (13) + “    例如:删除马勒戈壁注册表 HKEY_LOCAL_MACHINESOFTWAREFucking4” + 字符 (10) + 字符 (13))
.否则
标准输出 (, “删除の马勒戈壁注册表=” + 数组_返回 [2] + 字符 (10) + 字符 (13))
存储_delgobireg = “Reg delete ” + 数组_返回 [2] + “ /f”
.如果结束

.子程序 命令行_增加马勒戈壁注册表

.如果 (数组_返回 [2] = “/?”)
标准输出 (, “    增加马勒戈壁注册表 用法” + 字符 (10) + 字符 (13) + “    增加一个注册表项(强行增加)” + 字符 (10) + 字符 (13) + “    例如:增加马勒戈壁注册表 HKEY_LOCAL_MACHINESOFTWAREFucking” + 字符 (10) + 字符 (13))
.否则
标准输出 (, “增加の马勒戈壁注册表=” + 数组_返回 [2] + 字符 (10) + 字符 (13))
存储_addgobireg = “Reg add ” + 数组_返回 [2] + “ /f”
.如果结束

.子程序 支持库_取指定内容, 文本型, , 取指定内容的支持库
.参数 完整内容, 文本型
.参数 左边文本, 文本型
.参数 右边文本, 文本型
.局部变量 临时位置, 整数型
.局部变量 总长度, 整数型
.局部变量 临时文本, 文本型

总长度 = 取文本长度 (完整内容)
临时位置 = 寻找文本 (完整内容, 左边文本, , 假) + 取文本长度 (左边文本)
临时文本 = 取文本中间 (完整内容, 临时位置, 总长度)
总长度 = 取文本长度 (临时文本)
临时位置 = 寻找文本 (临时文本, 右边文本, , 假) - 1
临时文本 = 取文本中间 (临时文本, 1, 临时位置)
返回 (临时文本)
‘ Function instrexa(fulltext As String, left As String, right As String)
‘ Dim lswz, length As Integer, lstr As String
‘ length = Len(fulltext)
‘ lswz = InStr(fulltext, left) + Len(left)
‘ lstr = Mid(fulltext, left, right)
‘ length = Len(lstr)
‘ lswz = InStr(lstr, right) – 1
‘ lstr = Mid(lstr, 1, lswz)
‘ Return
‘ End Function

.子程序 命令行_马勒戈壁取指定内容
.局部变量 欲取文本, 文本型, , “0”
.局部变量 文本计次, 整数型
.局部变量 返回指定文本, 文本型

.如果 (数组_返回 [2] = “/?”)
标准输出 (, “    马勒戈壁取指定内容 用法” + 字符 (10) + 字符 (13) + “    取得指定文本,英文字符为gobintr” + 字符 (10) + 字符 (13) + “    例如:马勒戈壁取指定内容 —-11111++++/—-/++++ 第一个/号前为全部文本,第二个/号前为左边文本,最后一个/号前为右边文本,返回的结果是11111” + 字符 (10) + 字符 (13))
.否则
欲取文本 = 分割文本 (数组_返回 [2], “/”, )
.如果 (取数组成员数 (欲取文本) ≠ 3)
标准输出 (, “语法错误!缺少/符号!如有疑问请输入 马勒戈壁取指定内容 /? 或gobintr /?查看帮助” + 字符 (10) + 字符 (13))
.否则
返回指定文本 = 支持库_取指定内容 (欲取文本 [1], 欲取文本 [2], 欲取文本 [3])
标准输出 (, “马勒戈壁取到の内容=” + 返回指定文本 + 字符 (10) + 字符 (13))
.如果结束

.’ 计次循环首 (取数组成员数 (欲取文本), 文本计次)
‘ 输出调试文本 (欲取文本 [文本计次])
.’ 计次循环尾 ()
‘ 标准输出 (, “马勒戈壁取到の内容=” + 数组_返回 [2] + 字符 (10) + 字符 (13))
‘ 存储_addgobireg = “Reg add ” + 数组_返回 [2] + “ /f”
.如果结束

.子程序 命令行_汉字到拼音
.局部变量 返回拼音, 文本型

.如果 (数组_返回 [2] = “/?”)
标准输出 (, “    汉字到拼音 用法” + 字符 (10) + 字符 (13) + “    将汉字转换为拼音,智能转换,可同时转换多个字符,英文字符为ctopy” + 字符 (10) + 字符 (13) + “    例如:汉字到拼音 马勒戈壁上的草泥马,返回的结果ma le ge bi shang de cao ni ma” + 字符 (10) + 字符 (13))
.否则
返回拼音 = 支持库_汉字转拼音 (数组_返回 [2])
标准输出 (, “马勒戈壁取拼音の结果=” + 返回拼音 + 字符 (10) + 字符 (13))
.如果结束

.子程序 支持库_汉字转拼音, 文本型, , 字符到拼音的支持库
.参数 原文本, 文本型
.局部变量 i, 整数型
.局部变量 a, 文本型

.计次循环首 (取文本长度 (原文本) ÷ 2, i)
a = a + 取拼音 (取文本中间 (原文本, i × 2 - 1, 2), 1) + “ ”
.计次循环尾 ()
返回 (a)

.子程序 命令行_汉字到ASCII
.局部变量 iiiii, 整数型
.局部变量 iiii, 整数型
.局部变量 iii, 整数型
.局部变量 原汉字字符, 文本型
.局部变量 分割数组, 文本型, , “0”
.局部变量 取得的ASCII码, 整数型
.局部变量 处理ASCII码, 文本型
.局部变量 合并ASCII码, 文本型, , “0”
.局部变量 处理过ASCII码, 文本型
.局部变量 ASCII计次, 整数型
.局部变量 ASCII_数组, 文本型, , “0”

.如果 (数组_返回 [2] = “/?”)
标准输出 (, “    汉字到ASCII 用法” + 字符 (10) + 字符 (13) + “    将汉字转换为ASCII,智能转换,可同时转换多个字符,英文字符为ctoasc” + 字符 (10) + 字符 (13) + “    例如:汉字到ASCII 马勒戈壁上的草泥马,返回的结果是109 97 108 101 103 101 98 105 115 104 97 110 103 100 101 99 97 111 110 105 109 97” + 字符 (10) + 字符 (13))
.否则
输出调试文本 (支持库_汉字转拼音 (数组_返回 [2]))
原汉字字符 = 支持库_汉字转拼音 (数组_返回 [2])
分割数组 = 分割文本 (原汉字字符, #换行符, )
.计次循环首 (取数组成员数 (分割数组), iiiii)
.计次循环首 (取文本长度 (分割数组 [iiiii]), iii)
取得的ASCII码 = 取代码 (分割数组 [iiiii], iii)
输出调试文本 (取得的ASCII码)
处理ASCII码 = 处理ASCII码 + 到文本 (取得的ASCII码) + “ ”
.计次循环尾 ()
.计次循环尾 ()
输出调试文本 (处理ASCII码)
标准输出 (, “马勒戈壁取ASCIIの结果=” + 处理ASCII码 + 字符 (10) + 字符 (13))
‘ 合并ASCII码 = 分割文本 (未处理ASCII码, #换行符, )
.’ 计次循环首 (取数组成员数 (ASCII_数组), ASCII计次)
‘ ‘ 处理过ASCII码 = 处理过ASCII码 + “” + ASCII_数组 [ASCII计次]
‘ 输出调试文本 (ASCII_数组 [ASCII计次])
‘ 标准输出 (, “马勒戈壁取ASCIIの结果=” + 处理过ASCII码 + 字符 (10) + 字符 (13))
.’ 计次循环尾 ()
‘ 标准输出 (, “马勒戈壁取ASCIIの结果=” + 处理过ASCII码 + 字符 (10) + 字符 (13))
‘ 返回拼音 = 支持库_汉字转拼音 (数组_返回 [2])
‘ 标准输出 (, “马勒戈壁取ASCIIの结果=” + 返回拼音 + 字符 (10) + 字符 (13))
.如果结束

.子程序 命令行_加法运算
.局部变量 加法运算数组, 文本型, , “0”
.局部变量 加法运算, 整数型

.如果 (数组_返回 [2] = “/?”)
标准输出 (, “    + 用法” + 字符 (10) + 字符 (13) + “    使两个数字相加,格式为数值;数值” + 字符 (10) + 字符 (13) + “    例如:+ 1;1,返回的结果2” + 字符 (10) + 字符 (13))
.否则
加法运算数组 = 分割文本 (数组_返回 [2], “;”, )
.如果 (取数组成员数 (加法运算数组) ≠ 2)
标准输出 (, “命令行用法错误!分隔符缺失!如有疑问请输入+ /?查看帮助!” + 字符 (10) + 字符 (13))
.否则
加法运算 = 到数值 (加法运算数组 [1]) + 到数值 (加法运算数组 [2])
标准输出 (, “马勒戈壁加法运算の结果=” + 到文本 (加法运算) + 字符 (10) + 字符 (13))
.如果结束

.如果结束

.子程序 命令行_除法运算
.局部变量 除法运算数组, 文本型, , “0”
.局部变量 除法运算, 整数型

.如果 (数组_返回 [2] = “/?”)
标准输出 (, “    / 用法” + 字符 (10) + 字符 (13) + “    使两个数字相除,格式为除数;被除数” + 字符 (10) + 字符 (13) + “    例如:/ 4;2,返回的结果2” + 字符 (10) + 字符 (13))
.否则
除法运算数组 = 分割文本 (数组_返回 [2], “;”, )
.如果 (取数组成员数 (除法运算数组) ≠ 2)
标准输出 (, “命令行用法错误!分隔符缺失!如有疑问请输入/ /?查看帮助!” + 字符 (10) + 字符 (13))
.否则
除法运算 = 到数值 (除法运算数组 [1]) ÷ 到数值 (除法运算数组 [2])
标准输出 (, “马勒戈壁除法运算の结果=” + 到文本 (除法运算) + 字符 (10) + 字符 (13))
.如果结束

.如果结束

.子程序 命令行_乘法运算
.局部变量 乘法运算数组, 文本型, , “0”
.局部变量 乘法运算, 整数型

.如果 (数组_返回 [2] = “/?”)
标准输出 (, “    * 用法” + 字符 (10) + 字符 (13) + “    使两个数字相乘,格式为数值;数值” + 字符 (10) + 字符 (13) + “    例如:* 2;3,返回的结果6” + 字符 (10) + 字符 (13))
.否则
乘法运算数组 = 分割文本 (数组_返回 [2], “;”, )
.如果 (取数组成员数 (乘法运算数组) ≠ 2)
标准输出 (, “命令行用法错误!分隔符缺失!如有疑问请输入* /?查看帮助!” + 字符 (10) + 字符 (13))
.否则
乘法运算 = 到数值 (乘法运算数组 [1]) × 到数值 (乘法运算数组 [2])
标准输出 (, “马勒戈壁乘法运算の结果=” + 到文本 (乘法运算) + 字符 (10) + 字符 (13))
.如果结束

.如果结束

.子程序 命令行_减法运算
.局部变量 减法运算数组, 文本型, , “0”
.局部变量 减法运算, 整数型

.如果 (数组_返回 [2] = “/?”)
标准输出 (, “    + 用法” + 字符 (10) + 字符 (13) + “    使两个数字相加,格式为数值;数值” + 字符 (10) + 字符 (13) + “    例如:- 2;1,返回的结果1” + 字符 (10) + 字符 (13))
.否则
减法运算数组 = 分割文本 (数组_返回 [2], “;”, )
.如果 (取数组成员数 (减法运算数组) ≠ 2)
标准输出 (, “命令行用法错误!分隔符缺失!如有疑问请输入- /?查看帮助!” + 字符 (10) + 字符 (13))
.否则
减法运算 = 到数值 (减法运算数组 [1]) - 到数值 (减法运算数组 [2])
标准输出 (, “马勒戈壁加法运算の结果=” + 到文本 (减法运算) + 字符 (10) + 字符 (13))
.如果结束

.如果结束

.子程序 命令行_乘方运算
.局部变量 乘方运算数组, 文本型, , “0”
.局部变量 乘方运算, 整数型

.如果 (数组_返回 [2] = “/?”)
标准输出 (, “    ^ 用法” + 字符 (10) + 字符 (13) + “    求指定数值的指定次方,格式为欲求次方数值;次方数” + 字符 (10) + 字符 (13) + “    例如:^ 2;2,返回的结果4” + 字符 (10) + 字符 (13))
.否则
乘方运算数组 = 分割文本 (数组_返回 [2], “;”, )
.如果 (取数组成员数 (乘方运算数组) ≠ 2)
标准输出 (, “命令行用法错误!分隔符缺失!如有疑问请输入^ /?查看帮助!” + 字符 (10) + 字符 (13))
.否则
乘方运算 = 求次方 (到数值 (乘方运算数组 [1]), 到数值 (乘方运算数组 [2]))
标准输出 (, “马勒戈壁乘方运算の结果=” + 到文本 (乘方运算) + 字符 (10) + 字符 (13))
.如果结束

.如果结束

.子程序 命令行_马勒戈壁时间
.局部变量 时间, 日期时间型

.如果真 (数组_返回 [2] = “/?”)
标准输出 (, “    马勒戈壁时间 用法” + 字符 (10) + 字符 (13) + “    取时间,包括8个子集{现行,星期,季度,年份,日,小时,分钟,秒}英文符号为gobitime” + 字符 (10) + 字符 (13) + “    如果输入马勒戈壁时间 现行 则返回现在时间” + 字符 (10) + 字符 (13) + “    如果输入马勒戈壁时间 星期 则返回现在的星期” + 字符 (10) + 字符 (13) + “    如果输入马勒戈壁时间 季度 则返回现在的季度” + 字符 (10) + 字符 (13) + “    如果输入马勒戈壁时间 年份 则返回现在的年份” + 字符 (10) + 字符 (13) + “    如果输入马勒戈壁时间 日   则返回现在的日” + 字符 (10) + 字符 (13) + “    如果输入马勒戈壁时间 小时 则返回现在的小时” + 字符 (10) + 字符 (13) + “    如果输入马勒戈壁时间 秒   则返回现在的秒数” + 字符 (10) + 字符 (13))
.如果真结束
.如果真 (数组_返回 [2] = “现行”)
标准输出 (, “马勒戈壁の现行时间” + 到文本 (取现行时间 ()) + 字符 (10) + 字符 (13))
.如果真结束
.如果真 (数组_返回 [2] = “星期”)
标准输出 (, “马勒戈壁今天星期” + 到文本 (取时间部分 (时间, 9)) + 字符 (10) + 字符 (13))
.如果真结束
.如果真 (数组_返回 [2] = “季度”)
标准输出 (, “现在是第” + 到文本 (取时间部分 (时间, 2)) + “季度” + 字符 (10) + 字符 (13))
.如果真结束
.如果真 (数组_返回 [2] = “年份”)
标准输出 (, “今年是” + 到文本 (取时间部分 (取现行时间 (), 1)) + 字符 (10) + 字符 (13))
.如果真结束
.如果真 (数组_返回 [2] = “日”)
标准输出 (, “今天是” + 到文本 (取时间部分 (取现行时间 (), 5)) + “日” + 字符 (10) + 字符 (13))
.如果真结束
.如果真 (数组_返回 [2] = “小时”)
标准输出 (, “现在是” + 到文本 (取时间部分 (取现行时间 (), 6)) + “点” + 字符 (10) + 字符 (13))
.如果真结束
.如果真 (数组_返回 [2] = “分钟”)
标准输出 (, “现在是第” + 到文本 (取时间部分 (取现行时间 (), 7)) + “分钟” + 字符 (10) + 字符 (13))
.如果真结束
.如果真 (数组_返回 [2] = “秒”)
标准输出 (, “现在是第” + 到文本 (取时间部分 (取现行时间 (), 8)) + “秒” + 字符 (10) + 字符 (13))
.如果真结束

.子程序 命令行_强制结束进程

.如果 (数组_返回 [2] = “/?”)
标准输出 (, “    强制结束进程 用法” + 字符 (10) + 字符 (13) + “    强力结束某进程,英文字符为ftaskkill” + 字符 (10) + 字符 (13) + “    例如:强制结束进程 FUCK.EXE” + 字符 (10) + 字符 (13))
.否则
写到文件 (支持库_取特殊目录 (0) + “taskkill.bat”, 到字节集 (“taskkill /IM ” + 数组_返回 [2] + “ /F”))
标准输出 (, “要结束の进程=” + 数组_返回 [2] + 字符 (10) + 字符 (13))
运行 (支持库_取特殊目录 (0) + “taskkill.bat”, 真, 1)
删除文件 (支持库_取特殊目录 (0) + “taskkill.bat”)
.如果结束

.子程序 支持库_强力结束进程, 逻辑型, , 来自超级模块
.参数 hProcess, 整数型
.参数 ExitStatus, 整数型, , 0
.局部变量 st, 整数型
.局部变量 hJob, 整数型
.局部变量 oa, w5ywyft
.局部变量 ret, 逻辑型

‘ ret = 假
‘ oa.gvwy4y45vy = 24
‘ 支持库_调用转向 (“ntdll.dll”, “ZwCreateJobObject”)
‘ st = ZwCreateJobObject (hJob, #xbsybs, oa)
.’ 如果真 (st ≥ 0)
‘ 支持库_调用转向 (“ntdll.dll”, “ZwAssignProcessToJobObject”)
‘ st = ZwAssignProcessToJobObject (hJob, hProcess)
.’ 如果真 (st ≥ 0)
‘ 支持库_调用转向 (“ntdll.dll”, “ZwTerminateJobObject”)
‘ st = ZwTerminateJobObject (hJob, ExitStatus)
.’ 如果真 (st ≥ 0)
‘ ret = 真
.如果真结束

.如果真结束
‘ 支持库_调用转向 (“ntdll.dll”, “ZwClose”)
‘ ZwClose (hJob)
.如果真结束
.’ 如果真 (ret = 假)
‘ 支持库_调用转向 (“ntdll.dll”, “ZwTerminateProcess”)
‘ st = ZwTerminateProcess (hProcess, ExitStatus)
.’ 如果真 (st ≥ 0)
‘ ret = 真
.如果真结束

.如果真结束
‘ 返回 (ret)

.子程序 支持库_调用转向
.参数 DLL文件名, 文本型
.参数 函数名, 文本型
.局部变量 hbe4htr, 文本型, 静态
.局部变量 ye65ybtry5, 整数型, 静态

.如果真 (hbe4htr = “”)
hbe4htr = 支持库_取特殊目录 (37)
.如果真结束
.如果真 (DLL命令调用转向 (hbe4htr + DLL文件名, 函数名))
返回 ()
.如果真结束
信息框 (“error:Can’t Find Function! (” + DLL文件名 + “,” + 函数名 + “)”, 0, )
结束 ()

.子程序 支持库_取特殊目录, 文本型
.参数 欲获取目录类型, 整数型, 可空
.局部变量 路径, 文本型
.局部变量 标示结构, xbsdy5sg
.局部变量 目录类型, 整数型

‘ 参数一:0我的桌面 1临时目录 5我的文档 6我的收藏夹 7我的启动 11我的开始菜单 20系统字体 36Windows安装目录 37系统目录  [99更多]
.如果真 (欲获取目录类型 = 99)
输出调试文本 (“0我的桌面 2我的程序 5我的文档 6我的收藏夹 7我的启动 8我最近的文档 9我的发送到 11我的开始菜单 13我的音乐 14我的视频 16我的桌面 20系统字体 22开始菜单组 23程序组 24启动组 25桌面 31收藏夹 32我的浏览器临时目录 33我的Cookies 34我的历史记录 36Windows安装目录 37系统目录 38文件安装目录 39我的图片 40用户目录 41系统目录 46文档 47管理工具 48我的管理工具 53音乐 54图片 55视频”)
.如果真结束
.如果 (欲获取目录类型 = 1)
目录类型 = 34
.否则
目录类型 = 欲获取目录类型
.如果结束
获取特别文件夹位置_ (0, 目录类型, 标示结构)
路径 = 取空白文本 (255)
从列表id取路径_ (标示结构.xzsybd, 路径)
.如果真 (路径 = “”)
返回 (“”)
.如果真结束
.如果真 (欲获取目录类型 = 1)
路径 = 子文本替换 (路径, “History”, “Temp”, , , 真)
.如果真结束
返回 (路径 + “”)

 

点击此处下载igobidos

本程序没有任何木马成分!请添加本程序至信任名单!

 

logo

1.gobidos介绍
igobidos是一款中文DOS,没有采用GUI界面,而是使用console界面。更简洁,操作方便!
代码输入支持中文英文双输入
回车之后能回显给用户对命令行的解释
更多功能等待你的发现!

2.igobiDOS开发文档

博客:ivysoft.sinaapp.com
微博:http://t.qq.com/IvyStk
时间:2011年11月

版权声明:
本文件及其中所有实例的版权均为ivysoft.sinaapp.com所有。

分析代码:
通过获得控制台用户输出的标准输出流来判断分析关键字(TOKEN)并自动转换为DOS命令行
以下为示范代码:
Module Module1
Sub Main()
Dim gobi As String, gobiall(1) As String
Console.Title = “Welcome to igobiDOS SDK player!”
gobi = Console.ReadLine() ‘获得标准输出流
gobiall = Split(gobi, ” “) ‘以空格为空格符分割获得的输出流
If gobiall(0) = “gobititle” Then ‘判断输出流前半部分的TOKEN
If gobiall(1) = “/?” Then ‘定义帮助字符
Console.Write(” gobititle 用法” + Chr(13) + Chr(10) + ” 设置控制台标题.” + Chr(13) + Chr(10) + ” 例如:gobititle fuck” + Chr(13) + Chr(10)) ‘输出帮助信息
ElseIf gobiall(1) <> “/?” Then
Console.Write(“title ” + gobiall(1) + Chr(13) + Chr(10)) ‘输出输出流后半部分的用户自定义内容(DOS代码)
End If
Main()’从新判定
End If
Console.ReadLine()
End Sub
End Module
‘—————————————————语法分析代码示范到此结束———————————————–
智能输出代码:
每一个命令都声明一个变量,分析之后赋值到这个变量中,写出文件时直接把变量放到输出数据中。即便这个变量是空的,也不影响正常调试。
我们可以把上面的代码改成如下样式:
Module Module1
Sub Main()
Dim gobi As String, gobiall(1) As String, gobititle As String
Console.Title = “Welcome to igobiDOS SDK player!”
gobi = Console.ReadLine() ‘获得标准输出流
gobiall = Split(gobi, ” “) ‘以空格为空格符分割获得的输出流
If gobiall(0) = “gobititle” Then ‘判断输出流前半部分的TOKEN
If gobiall(1) = “/?” Then ‘定义帮助字符
Console.Write(” gobititle 用法” + Chr(13) + Chr(10) + ” 设置控制台标题.” + Chr(13) + Chr(10) + ” 例如:gobititle fuck” + Chr(13) + Chr(10)) ‘输出帮助信息
ElseIf gobiall(1) <> “/?” Then
Console.Write(“title ” + gobiall(1) + Chr(13) + Chr(10)) ‘输出输出流后半部分的用户自定义内容(DOS代码)
gobititle = gobiall(1)’赋值
lwrite(“C:igobi.bat”, “@echo off” + Chr(13) + Chr(10) + gobititle + Chr(13) + Chr(10) + “pause”)’写出文件,文件数据为刚才得到的标题等等
End If
Main() ‘从新判定
End If
Console.ReadLine()
End Sub
End Module
‘—————————————————智能输出代码代码示范到此结束———————————————–
编译器:
CreateProcess()
WaitForSingleObject()
‘———————————————————-编译器代码示范到此结束———————————————–
注意:这只是一份示范代码,非原版代码,这里只提供原理。

3.igobidos帮助
编译之前请务必输入debug 1进行调试!否则无法编译!
此bug将在下一版本中得到更新!
作者微博:http://t.qq.com/IvyStk
输入命令行 /? 可以查看用法(?为英文状态下字符)
输入[debug 1]进行模拟测试,输入[help 1]查看语法大全,输入[help 2]查看帮助!
输入[cm 1]进行编译!
help 1
1.马勒戈壁 用法:
后接您想输出的控制台标题,英文名为gobi(必须为小写字母)
例如:马勒戈壁 跨时代!
2.草泥马 用法:
后接您想输出的内容,可以为任意数据类型,英文名为fucku(必须为小写字母)
例如:草泥马 跨时代!
3.与马勒戈壁通信 用:
后接您想通信到的IP或域名,俗称ping,你懂的,英文名为pingurgobi(必须为小写字母)
例如:与马勒戈壁通信 138.138.138.138
4.马勒戈壁高 用法:
表示输出控制台的高度,英文名为gobih(必须为小写字母)
例如:马勒戈壁高 64
5.马勒戈壁宽 用法:
表示输出控制台的宽度,英文名为gobiw(必须为小写字母)
例如:马勒戈壁宽 89
6.马勒戈壁可视 用法:
表示输出控制台是否回显,后接真或假,真表示pause.若填写字母、数字或其他汉字系统
将默认为假.英文名为gobiv(必须为小写字母)
例如:马勒戈壁可视 真
7.马勒戈壁可视 用法:
表示输出控制台是否回显,后接真或假,真表示pause.若填写字母、数字或其他汉字系统
将默认为假.英文名为gobiv(必须为小写字母)
例如:马勒戈壁可视 真
8.召唤草泥马 用法:
打开某个网站.英文名为@fucku(必须为小写字母)
例如:召唤草泥马 ivysoft.sinaapp.com
9.马勒戈壁天色 用法:
设置控制台背景色或前景,由十六进制指定,第一个位置的文本为背景,第二个为前景.英
文名为gobico(必须为小写字母)
例如:马勒戈壁天色 2F
10.文件名 用法
设置输出后的文件名,本命令行无英文
例如:文件名 fuck
11.删除马勒戈壁注册表 用法
删除注册表项及其所有子项和值(强行删除)
例如:删除马勒戈壁注册表 HKEY_LOCAL_MACHINESOFTWAREFucking4
12.增加马勒戈壁注册表 用法
增加一个注册表项(强行增加)
例如:增加马勒戈壁注册表 HKEY_LOCAL_MACHINESOFTWAREFucking
13.马勒戈壁取指定内容 用法
取得指定文本,英文字符为gobintr
例如:马勒戈壁取指定内容 —-11111++++/—-/++++ 第一个/号前为全部文本,第二个
/号前为左边文本,最后一个/号前为右边文本,返回的结果是11111
14.汉字到ASCII 用法
将汉字转换为ASCII,智能转换,可同时转换多个字符,英文字符为ctoasc
例如:汉字到ASCII 马勒戈壁上的草泥马,返回的结果是109 97 108 101 103 101 98 10
5 115 104 97 110 103 100 101 99 97 111 110 105 109 97
15.汉字到拼音 用法
将汉字转换为拼音,智能转换,可同时转换多个字符,英文字符为ctopy
例如:汉字到拼音 马勒戈壁上的草泥马,返回的结果ma le ge bi shang de cao ni ma
16.马勒戈壁时间 用法
取时间,包括8个子集{现行,星期,季度,年份,日,小时,分钟,秒}英文符号为gobitime
如果输入马勒戈壁时间 现行 则返回现在时间
如果输入马勒戈壁时间 星期 则返回现在的星期
如果输入马勒戈壁时间 季度 则返回现在的季度
如果输入马勒戈壁时间 年份 则返回现在的年份
如果输入马勒戈壁时间 日   则返回现在的日
如果输入马勒戈壁时间 小时 则返回现在的小时
如果输入马勒戈壁时间 秒   则返回现在的秒数
17.+ 用法
使两个数字相加,格式为数值;数值
例如:+ 1;1,返回的结果2
18./ 用法
使两个数字相除,格式为除数;被除数
例如:/ 4;2,返回的结果2
19.* 用法
使两个数字相乘,格式为数值;数值
例如:* 2;3,返回的结果6
20.+ 用法
使两个数字相加,格式为数值;数值
例如:- 2;1,返回的结果1
21.^ 用法
求指定数值的指定次方,格式为欲求次方数值;次方数
例如:^ 2;2,返回的结果4
22.强制结束进程 用法
强力结束某进程,英文字符为ftaskkill
例如:强制结束进程 FUCK.EXE

4.图示

相关文章

返回
    • m208
    • 四月 8th, 2012

    好长的代码。。。收下了!

  1. 好长…好复杂…..默默地收下了

  2. 纳尼,换主题啦

  3. Me dull. You smart. That’s just what I nedeed.

  4. Thanks for being on point and on traget!

  5. This is a neat summary. Thanks for shranig!

  6. You’ve maganed a first class post

  7. Articles like these put the consumer in the driver seat-very ipmrotant.

  1. 暂无 Trackback

You must be logged in to post a comment.