IVY DOM


 

人生就像一副复杂拼图
每个人总有属於自己的记忆碎片
优质美国空间-老薛主机|IVY DOM|Flowline|

联系我

RSS




十月 03, 2012

[开源]易语言仿C语言printf

.版本 2

.程序集 程序集1

.子程序 _启动子程序, 整数型, , 本子程序在程序启动后最先执行

printf (“我们%s”, , { “の” })
printf (“友谊不是%s”, , { “终点” })
printf (“%s”, , { “!” })
printf (“n”)
printf (“+%d”, { 10086 })
printf (“n你相信吗n哈哈哈n”)
getchar ()
返回 (0)  ‘ 可以根据您的需要返回任意数值

.子程序 printf
.参数 Text, 文本型
.参数 Integer, 整数型, 可空 数组
.参数 String, 文本型, 可空 数组
.局部变量 tke, 整数型, , , 是否找到n
.局部变量 tki, 整数型, , , 是否找到%d
.局部变量 tkc, 整数型, , , 是否找到%s
.局部变量 tkes, 文本型, , “0”
.局部变量 tkesn, 整数型, , , 记录n个数
.局部变量 tkis, 文本型, , “0”
.局部变量 tkisn, 整数型, , , 记录%d个数
.局部变量 tkcs, 文本型, , “0”
.局部变量 tkcsn, 整数型, , , 记录%s个数
.局部变量 r1, 文本型
.局部变量 r2, 文本型
.局部变量 r, 文本型
.局部变量 i, 整数型

tke = 寻找文本 (Text, #ENTER, 1, 真)
tki = 寻找文本 (Text, #INT, 1, 真)
tkc = 寻找文本 (Text, #CHAR, 1, 真)
.如果 (tke = -1 且 tki = -1 且 tkc = -1)
标准输出 (, Text)
.否则
.如果真 (tki = -1 且 tkc = -1)
tkes = 分割文本 (Text, #ENTER, )
.计次循环首 (取数组成员数 (tkes), i)
r = tkes [i] + 字符 (13) + 字符 (10)
标准输出 (, r)
.计次循环尾 ()
.如果真结束
.如果真 (tke = -1 且 tkc = -1)
标准输出 (, int (Text, Integer))
.如果真结束
.如果真 (tke = -1 且 tki = -1)
标准输出 (, char (Text, String))
.如果真结束
‘ i = 0
.’ 如果真 (tke = -1 且 tki ≠ -1 且 tkc ≠ -1)
‘ 输出调试文本 (Text)
‘ r1 = char (Text, String)
‘ 输出调试文本 (int (Text, Integer))

‘ 标准输出 (, int (r1, Integer))
.如果真结束
.’ 如果真 (tkc = -1)
‘ ‘ r2 = int (Text, Integer)
‘ ‘ 标准输出 (, enter (r2))
.如果真结束

‘ ‘ 标准输出 (, Text)
.如果结束

.子程序 char, 文本型
.参数 txt, 文本型
.参数 str, 文本型, 数组
.局部变量 tkcs, 文本型, , “0”
.局部变量 i, 整数型
.局部变量 r, 文本型

tkcs = 分割文本 (txt, #INT, )
.计次循环首 (取数组成员数 (tkcs), i)
r = r + 子文本替换 (tkcs [i], #CHAR, 到文本 (str [i]), , , 真)
.计次循环尾 ()
返回 (r)

.子程序 enter, 文本型
.参数 txt, 文本型
.局部变量 tkes, 文本型, , “0”
.局部变量 r, 文本型
.局部变量 i, 整数型

tkes = 分割文本 (txt, #ENTER, )
.计次循环首 (取数组成员数 (tkes), i)
r = tkes [i] + 字符 (13) + 字符 (10)
返回 (r)
.计次循环尾 ()
返回 (“”)

.子程序 int, 文本型
.参数 txt, 文本型
.参数 int, 整数型, 数组
.局部变量 tkis, 文本型, , “0”
.局部变量 r, 文本型
.局部变量 i, 整数型

tkis = 分割文本 (txt, #INT, )
.计次循环首 (取数组成员数 (tkis), i)
tkis [i] = tkis [i] + 到文本 (int [i])
r = r + tkis [i]
.计次循环尾 ()
返回 (r)

.子程序 getchar, 文本型

返回 (标准输入 ())

 

常量:

.版本 2

.常量 ENTER, ““n””
.常量 INT, ““%d””
.常量 CHAR, ““%s””

printf-易语言

相关文章

返回
    • ivy
    • 十月 3rd, 2012

    参数无限咱搞不得,直接用数组代替啦~总体来说呢就是寻找转义字符,分割之后的数组下标就是该转义符的个数,然后循环配对~可惜易语言似乎只能取变量地址没法取地址数据,否则用地址数组更方便

  1. 暂无 Trackback

You must be logged in to post a comment.